[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cvs commit as root

From: Harry Putnam
Subject: Re: cvs commit as root
Date: Fri, 07 Dec 2001 10:44:15 -0800
User-agent: Gnus/5.090004 (Oort Gnus v0.04) Emacs/21.1

address@hidden (Larry Jones) writes:

> Harry Putnam writes:
> > 
>> I'd like to override the taboo on committing as root. I imagine it is
>> possible but not clear how to do it.
> You're only not allowed to commit as root if CVS can't figure out who
> you really are.  As long as you login as yourself and then su to root
> (rather than logging in as root), CVS should be able to figure out who
> you really are.
> If you really want to eliminate the check, look for CVS_BADROOT in
> options.h.

Since I only have the problem on a solaris 8 (intel) machine.  I tried
recompiling there.  

First attempt with no special flags. Just ./configure Then edit
src/options.h. Then make.  But it errors out like this (Tail of


  gcc -DHAVE_CONFIG_H -I. -I. -I.. -I. -I../lib -I../diff -I../zlib
  -Iyes/include -g -O2 -c -o server.o `test -f server.c || echo
  server.c:31:21: krb5.h: No such file or directory
  make[3]: *** [server.o] Error 1
  make[3]: Leaving directory `/usr/local/src/cvs-1.11.1p1/src'
  make[2]: *** [all] Error 2
  make[2]: Leaving directory `/usr/local/src/cvs-1.11.1p1/src'
  make[1]: *** [all-recursive] Error 1
  make[1]: Leaving directory `/usr/local/src/cvs-1.11.1p1'
  make: *** [all] Error 2

Ok, so trying --disable-server

   # ./configure --disable-server
Same errors

Once again with a wild guess:
 # ./configure --disable-server --with-kerberos=no
Still get the same errors.

Why is the compile still looking for server realted files?  And can I
exclude kerberos stuff some home?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]