[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: corrupt binary files (with -kb)

From: Eric Siegerman
Subject: Re: corrupt binary files (with -kb)
Date: Tue, 11 Dec 2001 20:03:17 -0500
User-agent: Mutt/1.2.5i

On Tue, Dec 11, 2001 at 04:15:22PM -0800, Matt Lease wrote:
> I have a number of win2000 desktop boxes (with similar software ) accessing
> a remote CVS repository via SSH; on only one of these boxes, binaries
> recieved from a checkout are corrupt (and yes, the binaries are all tagged
> with -kb).
> The corrupt binaries are always slightly larger than the correct binary
> (e.g. 884 bytes vs 874 bytes, 462622 vs. 460570).

That last sounds as though the files are being treated as text,
despite the -kb settings -- <CR>s are being added to them.

Various things to look at (grasping at straws here):
  - Verify my guess that <CR>s are being added: write a little
    program to turn <LF> into <CR><LF>; do that to correct copies
    of a few files, and see if the results match what CVS is

  - Have you tried checking out a completely fresh sandbox on the
    offending machine, as opposed to "cvs update"ing an existing
    sandbox?  Perhaps the -kb's got lost somehow from the files'
    CVS/Entries lines; that would override the setting in the ,v
    files on the server, I think.

  - Are you using WinCVS or a straight command-line CVS?  If the
    former, I think it uses a DLL for the underlying CVS
    operations; so trying various versions of cvs.exe would have
    no effect.

  - Is there a .cvswrappers file on the offending client that
    says to treat all files as text?  There are a few
    "cvswrappers" files -- some on the server, but others on the
    client -- and an environment variable.

  - How about ~/.cvsrc (not sure what could have this effect, but
    it's worth looking at).

  - SSH settings (wherever on the windows box would be the
    equivalent of ~/.ssh).  There might be something funny there.

  - CygWin doesn't enter the picture, does it?

  - You don't say which versions you've tried on the client, or
    which version is running on the server.  That might be
    relevent.  SSH too, please.

  - Try "cvs -t update" (or checkout) on both the offending
    client and a working one.  Differences might be instructive.

Good luck.


|  | /\
|-_|/  >   Eric Siegerman, Toronto, Ont.        address@hidden
|  |  /
The world has been attacked.  The world must respond ... [but] we must
be guided by a commitment to do what works in the long run, not by what
makes us feel better in the short run.
        - Jean Chr├ętien, Prime Minister of Canada

reply via email to

[Prev in Thread] Current Thread [Next in Thread]