[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Add a file that has the same name as one that has been removed? - S

From: Michael Stammberger
Subject: Re: Add a file that has the same name as one that has been removed? - Solved!
Date: Wed, 12 Dec 2001 12:03:15 +0100


I have solved the problem.
After some hours of stupid searching in bug reports, newsgroups and
other sources I found out the reason for this strange behaviour of cvs.
I forgot to tell what configuration I use:
Windows NT with WinCVS 1.6b with cvs.exe Beta 2 (Build43) and
the server and the repository is stored on Linux (Suse 7.X) with cvs
1.11.1p1 - and I've installed these all since yesterday, because I
thought there is a bug in cvs ;-)

The reason is quite simple:
The old file that I have removed has had the name 'FrmStatus.frm'
The file name of the file I wanted to (re-)add was 'frmStatus.frm'

WinCVS is not case sensitive, so there was no problem for WinCVS with
the 'add' command. But the 'commit' has failed because of the case
differencies of the file names.

I think cvs should handle this in any better way - an assert is not
really a good solution ;-)


> I have to add a file to my repository that has the same filename as a
> file that has been removed and stays now in the 'Attic'...
> The 'add' command seems to be ok:
> cvs add frmStatus.frm (in directory L:\Develop\Projects\VB\IVV\)
> cvs server: re-adding file frmStatus.frm (in place of dead revision 1.2)
> cvs server: use 'cvs commit' to add these files permanently
> But the 'commit' ends with an Assertion:
> cvs commit -m "wrzlbrnft..." frmStatus.frm (in directory
> L:\Develop\Projects\VB\IVV\)
> RCS file: /develop/projects/VB/IVV/frmStatus.frm,v
> done
> cvs: commit.c:2056: checkaddfile: Assertion `*rcsnode == ((void *)0)'
> failed.
> cvs [server aborted]: received abort signal

reply via email to

[Prev in Thread] Current Thread [Next in Thread]