[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Readonly

From: vvor
Subject: RE: Readonly
Date: Wed, 13 Feb 2002 13:59:18 -0500

Thank you for responding!

I checked env on the server. CVSREAD was defined.

I commented it out, logged out, logged in (as root). Then I tried a
checkout: all files are still read-only. I tried cvs -w co module. Still

People have been using wincvs 1.0.6. does this add unremoveable watches or
locks? is there a way to unwatch/unlock the entire repository from cvs

I have a hunch that the cvs import problem is related. cvs imports do not
add modules to the modules file. Is there an admin file missing or
something? cvs version 1.11.


-----Original Message-----
From: address@hidden [mailto:address@hidden Behalf Of
Eric Siegerman
Sent: Wednesday, February 13, 2002 1:04 PM
Subject: Re: Readonly

On Wed, Feb 13, 2002 at 06:04:34AM -0500, vvor wrote:
> > I have tried for several eons to turn off read-only permissions. CVSREAD
> is
> > set to "no".

This looks like your problem.  If CVSREAD is *defined*, that's
enough to put CVS into read-only mode.  Its value is completely
ignored.  From src/main.c:
    if (getenv (CVSREAD_ENV) != NULL)
        cvswrite = 0;


|  | /\
|-_|/  >   Eric Siegerman, Toronto, Ont.        address@hidden
|  |  /
One ring to rule the mall.
        - Movie review headline, eye Magazine

Info-cvs mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]