[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

pserver permission

From: Zanabria, Moises
Subject: pserver permission
Date: Wed, 13 Feb 2002 15:04:12 -0600

Hi Guys:
I just finished a new installation of cvs (1.11.1p1) in a Linux Machine, I
create my repository and everything looks fine except that I tried to
configured the pserver method access, I was able to login creating the
~/.cvspass because the first time is not created.

I created my /etc/xinetd.d/cvspserver

service cvspserver
        disable = no
        socket_type     = stream
        protocol        = tcp
        wait            = no
        user            = root
        server          = /usr/local/bin/cvs
        server_args     = -f --allow-root=/local/cvs_security/src pserver

My /etc/services:

cvspserver      2401/tcp                        # CVS client/server
cvspserver      2401/udp                        # CVS client/server

I'm executing  a "cvs co CVSROOT "

When I run the EXT method I don't have any problem, the problem is when I
run pserver method.
I got :

cvs server: Updating CVSROOT
cvs server: failed to create lock directory for
(/local/cvs_security/src/CVSROOT/#cvs.lock): Permission denied
cvs server: failed to obtain dir lock in repository
cvs [server aborted]: read lock failed - giving up

My CVSROOT directory have g+s permission.
Any Ideas.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]