[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Readonly

From: Eric Siegerman
Subject: Re: Readonly
Date: Wed, 13 Feb 2002 14:09:53 -0500
User-agent: Mutt/1.2.5i

On Wed, Feb 13, 2002 at 01:59:18PM -0500, vvor wrote:
> I checked env on the server. CVSREAD was defined.
> I commented it out, logged out, logged in (as root).  Then I tried a
> checkout: all files are still read-only. I tried cvs -w co module. Still
> read-only.

Were these last tests local, on the server machine, or
client/server?  If the latter, try the former.  One step at a

Did you check that CVSREAD is *really* undefined?
        env | grep CVSREAD
should produce no output.

Also, check your umask.  (Long shot here; you'd likely already
have noticed if it was too restrictive.)

> People have been using wincvs 1.0.6. does this add unremoveable watches or
> locks? is there a way to unwatch/unlock the entire repository from cvs
> admin?

Unknown; I've never used watches, and rarely used WinCVS.  But
that's an old version, isn't it?  Try upgrading.

> I have a hunch that the cvs import problem is related. cvs imports do not
> add modules to the modules file. Is there an admin file missing or
> something?

Nope, this is (a) totally unrelated, and (b) not a problem.
Imports aren't *supposed* to change the modules file.

> cvs version 1.11.

Try upgrading that too, on both client and server.


|  | /\
|-_|/  >   Eric Siegerman, Toronto, Ont.        address@hidden
|  |  /
One ring to rule the mall.
        - Movie review headline, eye Magazine

reply via email to

[Prev in Thread] Current Thread [Next in Thread]