[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Readonly

From: vvor
Subject: RE: Readonly
Date: Thu, 14 Feb 2002 13:22:20 -0500

i set up wincvs 1.2, the latest version, using ssh and files are read-write
on at least 1 pc workstation!o, yay!

ssh is ok. pserver makes files read only. why would it do that?


-----Original Message-----
From: address@hidden [mailto:address@hidden Behalf Of
Sent: Wednesday, February 13, 2002 10:06 PM
To: Eric Siegerman; CVS
Subject: RE: Readonly

env | grep CVSREAD produces no output.

checkout on the server is now read-write. checkout on server (logged in as
non-root user), read-write.

on pc workstations, files are still readonly. same user on linux that got
read-write gets read only files on a pc. on macintosh, readonly. readonly

so, everyone but the server machine gets files read-only. why? is this


-----Original Message-----
From: address@hidden [mailto:address@hidden Behalf Of
Eric Siegerman
Sent: Wednesday, February 13, 2002 2:10 PM
Subject: Re: Readonly

On Wed, Feb 13, 2002 at 01:59:18PM -0500, vvor wrote:
> I checked env on the server. CVSREAD was defined.
> I commented it out, logged out, logged in (as root).  Then I tried a
> checkout: all files are still read-only. I tried cvs -w co module. Still
> read-only.

Were these last tests local, on the server machine, or
client/server?  If the latter, try the former.  One step at a

Did you check that CVSREAD is *really* undefined?
        env | grep CVSREAD
should produce no output.

Also, check your umask.  (Long shot here; you'd likely already
have noticed if it was too restrictive.)

> People have been using wincvs 1.0.6. does this add unremoveable watches or
> locks? is there a way to unwatch/unlock the entire repository from cvs
> admin?

Unknown; I've never used watches, and rarely used WinCVS.  But
that's an old version, isn't it?  Try upgrading.

> I have a hunch that the cvs import problem is related. cvs imports do not
> add modules to the modules file. Is there an admin file missing or
> something?

Nope, this is (a) totally unrelated, and (b) not a problem.
Imports aren't *supposed* to change the modules file.

> cvs version 1.11.

Try upgrading that too, on both client and server.


|  | /\
|-_|/  >   Eric Siegerman, Toronto, Ont.        address@hidden
|  |  /
One ring to rule the mall.
        - Movie review headline, eye Magazine

Info-cvs mailing list

Info-cvs mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]