[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

CVS checkout with remote repository question

From: Terry Spafford
Subject: CVS checkout with remote repository question
Date: Wed, 20 Feb 2002 13:39:36 -0800
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20011126 Netscape6/6.2.1

Hello, my name is Terry Spafford. Over the past few months the task of redesigning my company's Code Management system has fallen onto my shoulders. Our code management used to be handled using PVCS, but the management (and pretty much everyone else in the company. :) want to move this over to CVS. The good news is; we don't have to maintain the code history that's stored in PVCS; so we can start our CVS tree off with a clean slate. The bad news is, I've got a LOT of files and systems to figure out how to organize and meet our needs. (I'm having second thoughts on if my design is good enough though now, so I'll be following this post up with another outlining our needs and the design I came up with to see if anyone who knows the CVS system better can advise me on how to improve it)

After much mental debate and at least 1 case of throwing out everything and restarting, I finally came up with a design/organization that met the majority of our needs, and I designed a set of scripts that people could use to access the CVS tree, using a tree set up on my local box to test them.

Finally, today, I started to implement the tree in the remote box and I've slammed into a literal brick wall.

My scripts partly depend on being able to specify the directory where the code will be checked out into. When the tree was local on my box, I could use the command:
        cvs checkout -d <new_directory> -r <branch> <cvstree>
and it worked great. It put everything in <cvstree> into <new_directory> without any complaints.

But now, the CVS tree is on a remote box and it's a whole new ball game.

I have tried to do the exact same command as listed above and I'm getting the following error:

cvs [server aborted]: absolute pathname `new_directory' illegal for server

Yet if I remove the -d flag, everything works fine. (Other then the fact that it plops all the code down in <curdir>/<cvstree>

Does anyone know why this doesn't work, and how I might be able to make it work? I've only really had about 2 months worth of serious exposure to CVS now, so I know there is a tonne of things I don't know that would probably make my job easier. :)

Thank you for your help.

Terry Spafford
Software Engineer
Global Weather Dynamics Inc
Monterey, California, USA

reply via email to

[Prev in Thread] Current Thread [Next in Thread]