[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

CVS over SSH hangs

From: vkd
Subject: CVS over SSH hangs
Date: Thu, 09 May 2002 18:22:15 GMT

Hi, I am experiencing problems using ssh as a shell for CVS.

Everything works great except two things

1. There is a small hang during connection start up:

# ssh -v -v address@hidden
OpenSSH_2.9p2, SSH protocols 1.5/2.0, OpenSSL 0x0090602f
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Seeding random number generator
debug1: Rhosts Authentication disabled, originating port will not be
debug1: restore_uid
debug1: ssh_connect: getuid 0 geteuid 0 anon 1

---> small hang here <--- about 7-10 seconds

debug1: Connecting to zorro [] port 22.
debug1: temporarily_use_uid: 0/0 (e=0)
debug1: restore_uid

Remote box is running Solaris 7 with OpenSSH 3.1p1

2. CVS transfer completes, but the session just hangs there as though there
is no completion of communication:

# cvs login
# cvs co project
U project/utils/readme.txt
U project/utils/room.c
U project/utils/zrea.c     <--- Last file in project.

---> indefinate hang here. <---

What's weird is that if I go into utils area and do cvs update there, it
works fine. Cvs update results in the same hang when I do it on the whole
tree. I don't understand why this is going on.

I tried using pserver over ssh tunnel and that worked fine. Why isn't this

Here is what I have defined:


Any ideas?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]