[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: CVS over SSH hangs

From: Joseph Shraibman
Subject: Re: CVS over SSH hangs
Date: Mon, 13 May 2002 19:08:49 -0400
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417

I've been having a similar problem on a redhat box with the cvs-1.11.1p1-6.2
rpm installed. When I try to checkout a large project from the localhost with ssh the checkout hangs after random files, I have to cntrl+C and start it again, and again, and again until the whole project is finished. local and fork access on the localhost work. I can checkout on different machine (from the same server) with openssh-3.1p1 installed, so I assume the problem is the ancient version of ssh I have installed on the localhost:

 ~> ssh -V
ssh: SSH Version 2.0.13

Any ideas?

vkd wrote:
Hi, I am experiencing problems using ssh as a shell for CVS.

Everything works great except two things

1. There is a small hang during connection start up:

# ssh -v -v address@hidden
OpenSSH_2.9p2, SSH protocols 1.5/2.0, OpenSSL 0x0090602f
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Seeding random number generator
debug1: Rhosts Authentication disabled, originating port will not be
debug1: restore_uid
debug1: ssh_connect: getuid 0 geteuid 0 anon 1

---> small hang here <--- about 7-10 seconds

debug1: Connecting to zorro [] port 22.
debug1: temporarily_use_uid: 0/0 (e=0)
debug1: restore_uid

Remote box is running Solaris 7 with OpenSSH 3.1p1

2. CVS transfer completes, but the session just hangs there as though there
is no completion of communication:

# cvs login
# cvs co project
U project/utils/readme.txt
U project/utils/room.c
U project/utils/zrea.c     <--- Last file in project.

---> indefinate hang here. <---

What's weird is that if I go into utils area and do cvs update there, it
works fine. Cvs update results in the same hang when I do it on the whole
tree. I don't understand why this is going on.

I tried using pserver over ssh tunnel and that worked fine. Why isn't this

Here is what I have defined:


Any ideas?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]