[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Commit Error

From: Vijay Narayanan
Subject: RE: Commit Error
Date: Wed, 5 Jun 2002 18:18:28 +0530


Thanks for the mail. My problem was that I had to have the same file name
even the case mattered. I solved it by removing the ,v entriesfor the files
in the Attic as well as the repository directory and re-added the file back


-----Original Message-----
From: Peter Kesch [mailto:address@hidden
Sent: Monday, June 03, 2002 7:46 PM
To: address@hidden
Subject: AW: Commit Error

Hi ...

i got the same error after somebody deleted a file named e.g. 'data.cpp' and
tried to readd as 'Data.cpp'.

i posted it in the group but i seemed that no one could recreate this error.
i solved it by adding the old file again to the repository and then adding
the new file. after this i could delete the old file and the error was gone.
btw. the error appeared on a Linux cvs-Server and win 2000 DOS client.

i think there is a bug in handle filenames which are not added like they are
saved on disk.
of course this error only appears only with windows systems which are not
case sensitive.



-----Urspr√ľngliche Nachricht-----
Von: address@hidden [mailto:address@hidden Auftrag
von Vijay Narayanan
Gesendet: Montag, 3. Juni 2002 08:50
An: address@hidden
Betreff: Commit Error


One of the users committed the files and seemed to have deleted the file
from within WinCVS. And on readding the file and committing is getting the
following error.

cvs [server aborted]: received abort signal
cvs: hash.c:312: findnode: Assertion `key != ((void *)0)' failed.

Any suggestions!


Info-cvs mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]