[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: address@hidden

From: Vince Rice
Subject: RE: address@hidden
Date: Sat, 15 Jun 2002 10:36:26 -0500

Thanks for the reply, Noel.  I *welcome* the opportunity to at least talk
about this.

> One difference I've noticed, though, is that you're
> using local mode.  I always use client/server mode
> even when the repo is stored locally since I like the
> behaviour of client/server mode better.

I didn't think you could use client/server mode on Win32 without using
CVSNT.  And all of the warnings about it kept me from doing that when
:local: worked fine (at least until now. :) ).

Also, for someone ignorant of the differences, what is it you like better?
Or, if there is already a list somewhere, just direct me to that (I've seen
statements like this in the Cederqvist also, but I've never seen them

> Also, IIRC, there's a fork mode that makes local mode
> behave like client/server mode.  You might try playing
> around with this as well.

CVS 1.11.2 gave me this error when trying to use :fork:
   cvs commit: CVSROOT is set to use the :fork: access method but your
   cvs commit: CVS executable doesn't support it.
   cvs [commit aborted]: Bad CVSROOT: `:fork:e:\cvs'.

On reflection, this is because the Win32 binary is client only, i.e. the
(client) after the 1.11.2 above, and therefore doesn't support the remote
protocol even in its :fork: form (now that I think about it, this is also
why I've always used :local: on my W2K boxes).

> One more thing, I don't recall a cvs- ever
> being released although I could very well be wrong.
> Have you seen the problem with cvs-1.11.1p1?  Is the
> source for cvs- available anywhere so a diff
> can be made?

I honestly don't know.  The only thing I know about it is that the binary is
in the 1.3b8 WinCVS package.  I don't know how they built it, where it came
from, etc.  I only tried it on a whim (I don't use WinCVS).

My other problem is that I don't have Visual C++, so I can't compile CVS
from source, which I would need to do to try 1.11.1p1 (I see the source on
CVSHOME, but not the binary).

So, I can only use :local: with the Win32 client.  Using CVSNT requires me
to set up a service, etc., which is overkill for what I'm trying to
accomplish.  I'd really just like to see the bug fixed, but I don't even
know if it is a bug; that's why I posted here.

Thanks again for your reply,


reply via email to

[Prev in Thread] Current Thread [Next in Thread]