[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Newbie Q: "cannot open CVS/Entries for reading"

From: Mike Ayers
Subject: Re: Newbie Q: "cannot open CVS/Entries for reading"
Date: Sun, 04 Aug 2002 12:59:37 -0700
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1b) Gecko/20020721

        Order scrambled to get thought flow...

Albin Takami wrote:

 > To clarify, the repository location is the directory that you set the
 > CVSROOT variable to, right?

        Yes, but you should not need to set CVSROOT - in fact, I recommend
you don't.  Use the -d flag during checkout, and let the CVS
directories track the repository for you.

 >>Tried importing: cvs import -m "Imported sources"
 > /design/project/dig/V9/src
 >>digital start
 >>The system replies: directory /design/project/dig/V9/src is not
 >>within the repository
 >   That command makes no sense.  What are "digital" and "start"?
 > This is from the Reservist manual too (sect 3.1.1): cvs import -m
 > sources" yoyodyne/rdir yoyo start
 > I replaced the so called vendor tag "yoyo" with "digital" since
yoyo didn't
 > help me.

        Well, I don't remember what I set in there, because I haven't use the
vendor tag since import, so "yoyo" probably wouldn't have hurt you
either.  However, you are trying to import into an existing
repository.  While this is possible, and can be useful, it is not what
you want to do.

 >   `cvs checkout /design/project/dig/V9/src` is incorrect syntax.  If
 > you have built module src in CVSROOT /design/project/dig/V9, then you
 > should:
 > $ cvs -d /design/project/dig/V9 checkout src

        Have you tried this?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]