[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: authorization failed: no such repository

From: david
Subject: Re: authorization failed: no such repository
Date: Tue, 13 Aug 2002 08:00:04 -0500 (CDT)

> Hi all,
> I have used CVS for some months now and never had such a problem as the one
> I'm facing now.
> I have CVS installed on a IBM AIX. The repository is located on a solaris 8
> and is mounted on the AIX via NFS (If I remember well, you don't recommend
> to use NFS with CVS but untill now it has always worked and I have some
> reasons to leave it like this).
The standard recommendation is that you do not mount on NFS and use
local access.  Using NFS in other ways may be a bad idea, but IIRC
this hasn't yet been shown.  (BTW, when talking about repository
corruption, "until now it has always worked" isn't a very good reason.
In the first place, unless you specifically check you may miss some
cases of corruption; in the second place, this is sufficiently bad
that you don't want to take chances.)
> I can access CVS from my PC, using CVS under DOS, but when I try to connect
> from the solaris 8 I got the following unfriendly error message:
> >SOL8% cvs -d :pserver:address@hidden:2402/vns/cvsroot login

This is the way it is specified in the manual for 1.11.2; I don't
know how it is specified in earlier versions.  I haven't had to
specify a port (I assume you've got the usual AIX conflict there),
and so don't know if it works in general.

> >(Logging in to address@hidden)
> >CVS password:
> >2402/vns/cvsroot: no such repository

On the other hand, this shows that CVS is not parsing the CVSROOT
as you like, but is assuming 2402 is the start of the repository
location rather than the port.

What version of CVS are you using on AIX and the Solaris?

Now building a CVS reference site at

reply via email to

[Prev in Thread] Current Thread [Next in Thread]