[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

$CVS_USER won't expand in loginfo...

From: Rudman, Chris
Subject: $CVS_USER won't expand in loginfo...
Date: Tue, 3 Sep 2002 20:06:59 +0100


I'm using CVS v1.11 and i just can't seem to get the $CVS_USER environment
variable expanding in any of my *info files. I'm using pserver to connect
winCVS client to CVS on SunOS 5.8, and because not everybody has unix
accounts i have a cvs passwd file which looks something like:-


where cvsowner is the unix user which actually runs CVS, and the user1,2,3
are peoples windows logons. I can get $USER to expand, but this of course
expands into 'cvsowner' as the server user, and not the actual CVS user who
performed the commit. I've tried all sotrs of forms ($CVS_USER,
$CVS_USERNAME, %CVS_USER_NAME, ${CVS_USER}, etc etc), and i always get the
same error reported back:"cvs server: loginfo:27: no such internal variable
$CVS_USER". Scouring the web i can see this used to be a problem back in 98
and would have thought it was fixed by now!

In my loginfo file i only have a single line:-

^cgr_test /export/cvs/CVSROOT/loginfo.ksh $CVS_USER %{sVv}

I've also tried this just on the unix box (taking winCVS out of the
equation) and get the same result, and i tried using cvs v1.11.2 as well,
still with no results.

Can anyone help me access the real cvs user who performed an action in my
*info scripts please?



This e-mail and any attachment is for authorised use by the intended 
recipient(s) only.  It may contain proprietary material, confidential 
information and/or be subject to legal privilege.  It should not be copied, 
disclosed to, retained or used by, any other party.  If you are not an intended 
recipient then please promptly delete this e-mail and any attachment and all 
copies and inform the sender.  Thank you.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]