[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problems with rtag command in WinCVS

From: Jason . Gibbons
Subject: Problems with rtag command in WinCVS
Date: Fri, 13 Sep 2002 09:52:51 +0100

Here's the history of the problem:

I was labelling up a module in WinCVS and the message 'waiting for x's lock
in /<directory>' came up and wouldn't disappear.  I checked with the
developer, and he knew nothing about it, so I went into the repository and
deleted the #cvs.lock file which had this developer's name on it (as per
the Cederqvist).  Then WinCVS aborted the tagging with the message:

cvs [rtag] aborted: reading from server: Invalid argument.

This problem only affected the particular module that was under going a tag
when the intial 'waiting for lock in' popped up.  All the other modules I
tried to tag were fine.  I can also update and commit files in the problem
directory except for one particular file which seems to be causing all the
problems.  If I try to create a new version of that file, I get a similar

cvs [commit aborted]: reading from server: Invalid argument

When I try running similar commands from a dos prompt, I get a slightly
more informative errors:

cvs [rtag aborted]: could not open lock file '\\server\module\,file.cpp,'
File Exists.

When I then try to manually change the attributes of the file so that it
can be opened, I get a similar message, this time telling me that the
,file.cpp, file could not be renamed to file.cpp,v.

I guess that CVS is doing something odd to the read/write permissions as it
executes the rtag command for this particular file.  Is there anyway of
fixing this?  I haven't tried stopping and restarting the CVS service yet,
but that would be next on the list I suppose.   I really don't want to have
to reboot the server.

Many thanks to anyone who can help

Jason Gibbons

(A Clearcase user, new to CVS)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]