[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

cvswrappers questions

From: Ken Williams
Subject: cvswrappers questions
Date: Wed, 2 Oct 2002 20:04:30 +1000


I had one original problem, and now I have two. Here they are, in order:

Original problem: I have a binary file that I'd like to store in CVS. It's a file used on Mac OS X, and needs to have type/creator codes set properly in the filesystem. These codes don't survive a pass through the CVS repository (they are empty when the file is checked out).

So I figured I could tell CVS to execute the command "/Developer/Tools/SetFile -t ENDB -c ENDN %s" whenever it updates the file locally. However, I can't figure out how to do this. When I tried to add them to my CVSROOT/cvswrappers file, I started getting the error "cvs [server aborted]: -t/-f wrappers not supported by this version of CVS". How can I solve this problem?

I've got a remote repository that I access over SSH.

Second problem: now my CVSROOT/cvswrappers file is unusable because of the above error, and I can't commit changes in order to fix it - because of the same error. How can I fix it if I can't commit changes?

I didn't anticipate this problem, because the cvswrappers file shouldn't be matched by the wildcard I used. Here's what I committed in it:

 TC*References -f '/Developer/Tools/SetFile -t ENDB "%s"'


reply via email to

[Prev in Thread] Current Thread [Next in Thread]