[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cvswrappers questions

From: Eric Siegerman
Subject: Re: cvswrappers questions
Date: Wed, 2 Oct 2002 11:33:32 -0400
User-agent: Mutt/1.2.5i

On Wed, Oct 02, 2002 at 08:04:30PM +1000, Ken Williams wrote:
> "cvs [server aborted]: -t/-f wrappers not supported by this
> version of CVS".

The -t/-f functionality was removed quite some time ago.  If I
recall, it never worked well, and never worked at all
client/server.  If it's even documented, you must be using an
ancient CVS client (presumably the server is more recent, which
is why it fails).

I don't know how to make CVS do what you want.  I imagine people
will jump in and say "that's not CVS's job; do it with your build
system" :-/

> Second problem: now my CVSROOT/cvswrappers file is unusable 
> because of the above error, and I can't commit changes in order 
> to fix it - because of the same error.  How can I fix it if I 
> can't commit changes?

Hmm, not sure.  Fix it directly in the repo, I guess.  *shudder*
By which I do NOT mean to edit cvswrappers,v; but rather:
  - fix $CVSROOT/CVSROOT/cvswrappers
  - check out the CVSROOT module
  - fix <sandbox>/cvswrappers
  - commit
It'd be nice if CVS were more forgiving (i.e. if it reduced the
error to a warning if it was in an entry that's not triggered by
the current operation).


|  | /\
|-_|/  >   Eric Siegerman, Toronto, Ont.        address@hidden
|  |  /
The acronym for "the powers that be" differs by only one letter
from that for "the pointy-haired boss".

reply via email to

[Prev in Thread] Current Thread [Next in Thread]