[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cvswrappers questions

From: Ken Williams
Subject: Re: cvswrappers questions
Date: Fri, 4 Oct 2002 09:55:53 +1000

On Thursday, October 3, 2002, at 01:33  AM, Eric Siegerman wrote:

On Wed, Oct 02, 2002 at 08:04:30PM +1000, Ken Williams wrote:
"cvs [server aborted]: -t/-f wrappers not supported by this
version of CVS".

The -t/-f functionality was removed quite some time ago.  If I
recall, it never worked well, and never worked at all
client/server.  If it's even documented, you must be using an
ancient CVS client (presumably the server is more recent, which
is why it fails).

The client is:

  Concurrent Versions System (CVS) 1.10 `Halibut' (client/server)

which is the version distributed with OS X 10.1.

The server is:

  Concurrent Versions System (CVS) 1.10.8 (client/server)

I don't know how to make CVS do what you want.  I imagine people
will jump in and say "that's not CVS's job; do it with your build
system" :-/

Yeah, that's what people have said.

I do feel like that's not a very good answer, though, since all I'm claiming here is that certain types of files break just by going into and out of CVS. It seems like that might be something worth fixing in CVS.

Second problem: now my CVSROOT/cvswrappers file is unusable
because of the above error, and I can't commit changes in order
to fix it - because of the same error.  How can I fix it if I
can't commit changes?

Hmm, not sure.  Fix it directly in the repo, I guess.  *shudder*
By which I do NOT mean to edit cvswrappers,v; but rather:
  - fix $CVSROOT/CVSROOT/cvswrappers
  - check out the CVSROOT module
  - fix <sandbox>/cvswrappers
  - commit

Thanks, that seems to have worked.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]