[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

report on building CVS 1.11.2 on NT

From: Kris Thielemans
Subject: report on building CVS 1.11.2 on NT
Date: Wed, 9 Oct 2002 12:52:29 +0100


just to let you know:

I've successfully built CVS 1.11.2 on my NT 4.0 sp6a machine  using the
cygwin tools (which includes gcc 2.95.2). Just following the Unix
installation description worked fine. This CVS version also seems to run
fine on my NT machine.

I've also tried to use VC 6.0, but get stuck there during compilation:
nmake /f cvsnt.mak CFG="cvsnt - Win32 Debug"
.\lib\valloc.c(10) : fatal error C1083: Cannot open include file:
No such file or directory

Indeed, that file contains lines
# include "getpagesize.h"

I can compile that file by defining HAVE_GETPAGESIZE (changing the line in
windows-NT/config.h), but then of course I get a linking error

valloc.obj : error LNK2001: unresolved external symbol _getpagesize
.\WinDebug/cvs.exe : fatal error LNK1120: 1 unresolved externals

As I have the cygwin version, I'm not too worried about this, but for those
who wan tto investigate this further, it looks like there are 2 files
missing getpagesize.h and getpagesize.c.

Kris Thielemans
(kris.thielemans <at>
Imaging Research Solutions Ltd
Cyclotron Building
Hammersmith Hospital
Du Cane Road
London W12 ONN, United Kingdom

web site address:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]