[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with partially lost branch information

From: Karl-König Königsson
Subject: Re: Problem with partially lost branch information
Date: Thu, 21 Nov 2002 19:27:21 +0100
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016

Donald Sharp wrote:

I would suggest that the forv_ver1_02XXXXX branch tag doesn't exist in the first two directories. Since it
looks like you know the date when the tag was applied
you can pull a workspace with the cvs co -D <date> command
for those two directories and then apply the branch tag.

Both directories exists in the branch and there have been changes made in both.

"Build" contains a directory "tools" which has the same error, i.e. its CVS/Tag file contains a "N" and not a "T". "tools" in its turn contains four directories: "cmd", "lib", "src" and "wise"; two are OK and two are weird.

All files in these directories have the correct sticky tag; there seems not to be a problem with the files, just the structure. If I manually correct the erronous "N" entries and replace them with a "T" things work just fine. Adding, committing, you name it.

The problem with this solution is that it only fixes the symptoms; once I check out a new sandbox I'm back again with the missing branch tags on some directories.

Furthermore: this has worked in the past. I don't know what has changed but for those developers who has an old sandbox of this branch everything is hunk-dory. This error only appears if you check out the branch today (or rather if you did in the last week). I suppose I will have to go through the backups, but I'd rather not.

What I really like to know is 1) why this has happend, 2) how I can fix it, and 3) how I can prevent it from happening in the future.

   Karl-König Königsson

VOBSTER (n.) A strain of perfectly healthy rodent which develops cancer the moment it enter a laboratory. (The Meaning of Liff, Douglas Adams)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]