[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

cvs hangs while reporting 'version'

From: Harig, Mark A.
Subject: cvs hangs while reporting 'version'
Date: Fri, 3 Jan 2003 19:40:12 -0500

I am having a problem with cvs hanging before completing the execution
of the its command.  The problem I describe below occurs with every
cvs command I have tried ('update', 'diff', etc.)  The examples given
use the 'version' command to try to simplify the problem and avoid
any complications that come from specific files.  I have tried the
commands with two different repositories on the same server, but get
the same result.

CVS server version: 1.11.1p1
Server O/S: Linux kernel 2.4.18

CVS client version: 1.11.1p1
Client O/S: Linux kernel 2.4.7

1. Here is the first command I have tried, using '-t' to attempt to get
debugging information:

$ CVS_RSH=/usr/bin/ssh /usr/bin/cvs -d<host IP addr>:/path/to/repos -t
-f version
 -> main loop with CVSROOT=<host IP addr>:<absolute path>
Client: Concurrent Versions System (CVS) 1.11.1p1 (client/server)
 -> Starting server: /usr/bin/ssh <host IP addr> cvs server 
Server: Concurrent Versions System (CVS) 1.11.1p1 (client/server)

where, host IP address is given explicitly to avoid potential DNS
       absolute path is the path from root, /, to the CVS repository
       -f is given to avoid any possible ~/.cvsrc side effects

2. Here is the same command, but with 'strace' added to get some further
about what is happening:

$ CVS_RSH=/usr/bin/ssh strace /usr/bin/cvs -d<IP addr>:/path/to/repos -t
-f version

(much long output omitted)

read(5, "Valid-requests Root Valid-respon"..., 4096) = 596
write(4, "UseUnchanged\n", 13)          = 13
write(4, "Global_option -t\nversion\n", 25) = 25
read(5, "M ", 4096)                     = 2
read(5, "Concurrent Versions System (CVS)"..., 4096) = 58
write(1, "Server: Concurrent Versions Syst"..., 66Server: Concurrent
Versions System (CVS) 1.11.1p1 (client/server)
) = 66
read(5, "ok\n", 4096)                   = 3
close(4)                                = 0
munmap(0x40018000, 4096)                = 0

The above is NOT a typo.  After 'read(5,', the output hangs with the
following the '5,'.  I have left this run for nearly thirty minutes to
if there was a timeout condition, before using 'Ctrl-C' to halt the

Does anyone have any idea what is causing this to happen?  I have been
to get cvs clients to work with the cvs server from several different
but on some machines it gives the above behavior.

Some additional information: I can get cvs to work partially.  'cvs
update', for example works, except that it hangs after updating the
source files (Ctrl-C is
needed after the files have been updated).

'ssh' works seemlessly for logging onto the machine that is running the

Thank you in advance for any help you can provide!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]