[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: cvs hangs while reporting 'version' (SOLVED)

From: Harig, Mark A.
Subject: RE: cvs hangs while reporting 'version' (SOLVED)
Date: Mon, 6 Jan 2003 11:28:56 -0500

> -----Original Message-----
> From: Larry Jones [mailto:address@hidden
> Sent: Saturday, January 04, 2003 5:27 PM
> To: Harig, Mark A.
> Cc: address@hidden
> Subject: Re: cvs hangs while reporting 'version'
> Harig, Mark A. writes:
> > 
> > The above is NOT a typo.  After 'read(5,', the output hangs with the
> > cursor
> > following the '5,'.  I have left this run for nearly thirty 
> minutes to
> > see
> > if there was a timeout condition, before using 'Ctrl-C' to halt the
> > command.
> Try upgrading to the recently-released CVS 1.11.4.
> -Larry Jones

Thanks for the suggestion.  I upgraded my CVS client to 1.11.4.  cvs
hangs, but at a different place -- during a call to wait():

$ export CVS_RSH=/usr/bin/ssh
$ strace cvs -t -f -d<IP addr>:/path/to/cvs/repos version

(much text omitted)

write(4, "UseUnchanged\n", 13)          = 13
write(4, "Global_option -t\nversion\n", 25) = 25
read(5, "M ", 4096)                     = 2
read(5, "Concurrent Versions System (CVS)"..., 4096) = 58
write(1, "Server: Concurrent Versions Syst"..., 66Server: Concurrent
Versions System (CVS) 1.11.1p1 (client/server)
) = 66
read(5, "ok\n", 4096)                   = 3
fstat64(4, {st_mode=S_IFIFO|0600, st_size=0, ...}) = 0
close(4)                                = 0
munmap(0x40018000, 4096)                = 0
fstat64(5, {st_mode=S_IFIFO|0600, st_size=0, ...}) = 0
close(5)                                = 0
munmap(0x40019000, 4096)                = 0

Because my ssh connection has been working seemlessly between
the client and server machines, I did not suspect that it
could be the cause of the problem.  Nevertheless, I checked
the versions of openssh that I was running on the client
and the server.  Because they were different, I upgraded
the version I am running on the client machine to match
the version that I am running on the server machine.

This solved the problem.  cvs now works regardless of
whether I use cvs 1.11.4 or cvs 1.11.1p1 as the client.

For future reference to anyone else who might have this
problem, I was running openssh 2.9p2 on my client machine,
while running openssh 3.1p1 on my server machine.  The
"cvs problem" disappeared when I upgraded openssh on my
client machine to 3.1p1.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]