[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: "move away"

From: Matt Bishop
Subject: RE: "move away"
Date: Wed, 27 Aug 2003 15:26:37 -0700

I believe I have uncovered a bug in CVS add, where the CVS/Entries file
gets dinged when an add fails due to network problems.

If I call 'cvs update' or 'cvs update -P', I do not encounter the "in
the way" error.  If I run 'cvs update -d', I encounter the error.

The error occurs in a directory that is under CVS control.  The
directory is not listed in it's parent's CVS/Entries file.  It was there
earlier.  If I add back the directory to the Entries file, the call 'cvs
update -dP' works as expected.

Yesterday our network was having access problems such that I was not
able to see the CVS server.  I performed several 'cvs add' calls, but
they failed due to the network errors.  Today, the Entries file for the
dir I was trying to add into is missing a directory.  I can only
conclude that add failed, causing the Entries file to be incorrectly

I have searched the issue DB and have found several "Entries" file bugs
that might be similar, but none that match exactly.  I tried to file a
new report, but received this message:

Login Required          

You must login to the site to use the requested feature. Visit the login
page to login or to register for an account. Also, you must be a member
of this project. Request a role in this project to be given more

If you think you do have an account in this project, it is likely that
the project is locked or your account has been otherwise disabled. 

I am logged in, so I need join the project or something.  Do I need an


-----Original Message-----
From: Mark D. Baushke [mailto:address@hidden 
Sent: Wednesday, August 27, 2003 3:20 PM
To: Matt Bishop
Cc: CVS-II Discussion Mailing List
Subject: Re: "move away" 

Matt Bishop <address@hidden> writes:

> I get this error frequently when updating in a directory with 'cvs 
> update -dP':
> cvs update: move away; it is in the way
> C

This typically means that there is a in the repository, but
that you have a local that was not checked out of the
repository in the way.
> I am running CVS 1.11.5 for Windows; server is 1.11.6 on Linux.
> If I blow away, and re-update, the problem goes away for a 
> bit, then returns.

Try NOT using the -P switch, do the update and then do you build that
creates and then do another update and see what happens.

> If I update the file directly with 'cvs update -dP' the 
> update works as expected.
> I've searched Cederqvist, but found nothing.  Google doesn't offer 
> much more.

Hmmm... This one looks relevant:

Which mentions this problem as well...

        -- Mark

reply via email to

[Prev in Thread] Current Thread [Next in Thread]