[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: CVS checkouts hang

From: James R. Marcus
Subject: RE: CVS checkouts hang
Date: Fri, 17 Oct 2003 10:37:18 -0400

It took me a while to get back to this issue, partly because it happens
sporadically, but enough to be annoying.  Yesterday I compiled 1.11.9 on
a test machine and found that I could not get the repository to show up
in Eclipse 2.0.2 or 2.1.1.  I can co from command line, and from Wincvs.
Has anyone else had this problem with the Eclipse/CVS plug-in?


P.S. Sorry about my last post in HTML.

From: James R. Marcus 
Sent: Tuesday, September 30, 2003 10:27 AM
To: address@hidden
Subject: CVS checkouts hang 

I few months ago I posted this question to but didn't get a
response.  Other files are hanging now and the problem happens about
once a week.  I'm going to set the CVS_CLIENT_LOG variable today, but
wanted to know if there are other specific ways of troubleshooting CVS


A few months ago CVS checkouts in Eclipse started to hang checking out
the last binary file in a folder.  It didn't bother anyone much so it
was ignored since the binary was in a thirdparty directory and was
rarely checked out or updated.
The problem was when CVS checkouts from CruiseControl started failing on
the same binary and as a result the build would fail.  After a lot
troubleshooting, (no thanks to snotty tech support at Dell, who asked me
what do you expect from an unsupported OS) I got the motherboard
replaced and was happy to find the check outs fast without hangs.

Recently someone mentioned that the same file was hanging in Eclipse
I tried it from command line and it worked fine.  Then someone checked
in a new 4MB binary and that hung from command line and Eclipse.

When I was troubleshooting this problem the first time I saw that an
revealed this: read(0,1 and then just sat there until it timed out.

Does anyone have any thoughts on this issue?

cvs --version
Concurrent Versions System (CVS) 1.11.2 (client/server)

CVS server
pserver (internal)
Red Hat 7.3 2.4.18-4

Red Hat 8.0

Windows XP SP1

reply via email to

[Prev in Thread] Current Thread [Next in Thread]