[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

strange "it is in the way" message

From: Lars Huttar
Subject: strange "it is in the way" message
Date: Wed, 21 Apr 2004 16:39:23 -0500

Dear CVS list,

Googling on this question, I've seen it asked a couple of other times,
but have not seen an answer that fit my circumstances.

On a Windows 2000 server, I'm running 
   cvs.exe update -d -P -C

This machine is a test server; no development is done on it.
We just need to update it from the CVS server regularly,
ignoring any changes that might have been made on the test server.
Hence the -C (but this problem occurs with or without the -C).

Any files newly added to CVS (i.e. that don't exist on the
test server) get updated properly, i.e. get created on the
test server. But for every file that already exists on the test
server, I get the error,

  cvs update: move away cocoon/mount/data-server/sources/BPPP.xsp; it is in the 
  C cocoon/mount/data-server/sources/BPPP.xsp

For every file! Whether modified (locally or on the CVS server) or not.
And most importantly, files that have been modified on other
machines and committed to the CVS server do not get updated
(regardless of whether they were modified on the test server).

So my question is, how can I get "cvs update" to get the
latest revisions of files from the CVS server, even when
those files already exist on the local machine?  Cvs is supposed
to do that, but it isn't.

I've tried this with both a windows client (1.11.12 from,
and the Cygwin cvs client.

I've tried removing all CVS folders and all the files/folders
that come from CVS, and doing a new checkout from scratch.
This didn't fix the problem.

A work-around was to delete all the files that are governed by
CVS, then do a checkout. This works, but
(a) it's pretty inefficient in terms of bandwidth, and
(b) if the checkout fails due to network problems, as it often
  seems to do, the test server ends up with no files and people
  who are trying to use it get frustrated.

Thanks for any help! I've been struggling with this for over a


reply via email to

[Prev in Thread] Current Thread [Next in Thread]