[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

CVS corrupts binary files ...

From: Adrian Constantin
Subject: CVS corrupts binary files ...
Date: Fri, 4 Jun 2004 23:19:14 -0700 (PDT)

Hi all,

I've created a simple repository on a Linux server
with one module wich is a web site. My working
directory is on a Windows machine and I have to use
ssh to connect to the server. I've tried several ssh
clients and with all of them the checkout command
creates corrupted image files in my working directory.
The module has been imported on the Linux server, from
the server, and the checkout is done from the Windows

If I just copy the images with WinSCP they are ok.
If I import them (on Linux) and then check them out
(on Windows) the images get corrupted

Also text files do not transfer properly; there's a
strange square at the end of the lines after checkout.
Again copying with WinSPC is ok...

I thought maybe the ssh client does LF<->CR/LF
mapping, but I've tried several, including OpenSSH,
and thingd didn't change.

Must I tell explicitly to cvs that I transfer
text/binary files between different systems ?

Or maybe I can't have sources on Windows and Linux in
the same time and cvs to function correctly ?

Thank you
Timothy Madden

Do you Yahoo!?
Friends.  Fun.  Try the all-new Yahoo! Messenger. 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]