[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: /#cvs.lock): No such file or directoryctory for <some directory inre

From: Arthur Barrett
Subject: RE: /#cvs.lock): No such file or directoryctory for <some directory inrepository>
Date: Thu, 19 Aug 2004 09:50:33 +1000


Apologies for not replying sooner - but I've been following the discussion 
closely and talking with our developers to ensure that I understand what our 
position on this issue is.

You are using WinCVS which is a "front end" to CVSNT - CVSNT is the default 
client for WinCVS and TortoiseCVS.  CVSNT is also GNU/GPL/Freeware, and runs on 
Windows, Linux, Mac, Solaris, HPUX etc etc (and soon on IBM iSeries too!).

March Hare Software provide commercial support for CVSNT - hence my interest in 
finding the "correct" answer for you.

Using a sandpit with CVS (cvshome) and CVSNT clients is dangerous and not 
supported.  Since CVSNT is available for all platforms I suggest you use it on 
the linux box and client.  

You can use a CVS (cvshome) server and CVSNT client(s) however some of the more 
advanced features of CVSNT are not available:

You also mention the "line feeds only" setting (-kL) - the reason why you did 
not get much reaction on this is that this setting is ONLY available on CVSNT.

My suggestions to resolve your problem mostly concurr with the other responses:
1. Use the same client on both Linux and Windows (CVSNT 2.0.51c is a good 
choice here since it is the default WinCVS client).
2. Always commit from either linux OR windows.
3. you can automatically keep two sandboxes in synch using the POSTCOMMIT 
trigger in CVSNT (server).

I hope this information is helpful.  If you have more questions please do not 
hesitate to ask on the free open source newsgroup for CVSNT:

Professional support, training and installation is available from March Hare 


Arthur Barrett

-----Original Message-----
From:   address@hidden on behalf of Jim Page -
Sent:   Wed 8/18/2004 1:34 AM
To:     address@hidden
Subject:        /#cvs.lock): No such file or directoryctory for <some directory 

I found a post in an archive regarding this issue which came quite close to
an answer, but not quite. I thought I would share my efforts in case it
saves someone some time. Here is the root of teh original thread:


Running unix/Windows cvs clients on source located on a volume shared
between OSs, shared using either Samba or Windows Services for unix NFS (I
tried both). specifically, unix client: cvs (various versions 1.11.2 up to
the latest stable release, under linux). Windows clients: WinCVS and the
PushOK cvs proxy for VisualStudio. The server is a linux box running cvs
1.11.17, on slackware 9.


Running pretty much any cvs command on a client (unix or windows) results in
something like the following:

... cvs stuff ...
cvs status: Examining .
/#cvs.lock): No such file or directoryctory for `/home/cvsroot/blah
'vs status: failed to obtain dir lock in repository `/home/cvsroot/blah
cvs [status aborted]: read lock failed - giving up


Run dos2unix (or similar) on the CVS/Repository file in the client
directory. Note this problem is on the client, not the server. The problem
is that the DOS EOL at the end of the path in CVS/Repository is interpreted
as part of the path. This may be an incomplete fix, as I am a newvie running
a cvs server, but it seems to have worked for me with no ill effects.


Email the way you want it - scanned for viruses and unwanted content by 

Information regarding this service can be found at

Info-cvs mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]