[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

pserver login only works from remote connections!?

From: SainTiss
Subject: pserver login only works from remote connections!?
Date: Mon, 30 Aug 2004 15:56:09 +0200


I'm experiencing something very odd here...

I've got a CVS pserver set up locally, at port 7404... The pc is firewalled, so remote access need to be done via an ssh tunnel, with a parameter -L2401:<hostname>:7404

This works perfectly fine, and I can login in the pserver, and checkout modules...

However, when I try to login locally (where the ssh tunnel is not even needed), I get authorization failed, no matter what I try:

cvs -d :pserver:<user>@<hostname>:7404/<cvsroot> login

I've even tried setting up an ssh tunnel locally, to simulate a remote login, but to no avail...

Is this some cvs policy that pserver logins are not allowed locally? Or is this an option which can be enabled and disabled? I've also tried looking for logs, but failed to find any...

The computer is an iMac btw, and the cvs pserver is launched via xinetd, by an entry in inetd.conf:

<server name> stream tcp nowait root /usr/bin/env env -i /usr/bin/cvs -f --allow-root=<cvs root> pserver

Any ideas as to what goes wrong here?

Many thanks in advance,
Hans Schippers
FWO Aspirant
Formal Techniques in Software Engineering (FoTS)
University of Antwerp
Middelheimlaan 1
2020 Antwerpen - Belgium
Phone: +32 3 265 38 71
Fax: +32 3 265 37 77</x-tad-smaller>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]