[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

SSH connection from WinCvs

From: Didier
Subject: SSH connection from WinCvs
Date: Mon, 13 Sep 2004 14:47:34 +0200
User-agent: Opera M2/7.53 (Win32, build 3850)


I'm trying to establish SSH connection from WinCvs to my CVS server (linux). The server is running fine for a long time, with :pserver: acces from WinCvs.
I can also access (for a long time) my account via ssh, with Putty.
=> So I didn't change anything on the server side actually.
I can run "cvs -v" via plink, on the server, from a Windows console.
I get this response:
        Concurrent Versions System (CVS) 1.11.1p1 (client/server)

I found docs online, explaining how to install Putty plink pagent and WinCvs.
=> My WinCvs ( Preference Settings are:
[x] SSH client C:\Util\putty\plink.exe -i C:\Util\putty\key-private.PPK
  CVSROOT           :ext:address@hidden:/opt/champion/cvs-dev
(Opale is a Putty saved session)

But I get always the same error message from WinCvs:
cvs checkout: warning: unrecognized response `Syntaxe du nom de fichier, de r‚pertoire ou de volume incorrecte.
' from cvs server
cvs [checkout aborted]: end of file from server (consult above messages if any)

This looks like this error message described in the cvs help:
warning: unrecognized response `text' from cvs server
If text contains a valid response (such as ok) followed by an extra carriage return character (on many systems this will cause the second part of the message to overwrite the first part), then it probably means that you are using the :ext: access method with a version of rsh, such as most non-unix rsh versions, which does not by default provide a transparent data stream. In such cases you probably want to try :server: instead of :ext:. If text is something else, this may signify a problem with your CVS server. Double-check your installation against the instructions for setting up the CVS server.

But I tried with :server: it doesn't change anything.
I don't know what to change in the server settings, because it works fine in :pserver: mode.

Could anyone give me some ideas ?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]