[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: waiting for lock message on cvs

From: Mark D. Baushke
Subject: Re: waiting for lock message on cvs
Date: Tue, 28 Sep 2004 09:35:17 -0700

<#part sign=pgp address@hidden>
Melroy <address@hidden> writes:

> I did a very stupid mistake while trying to
> commit something ona new machine.

> when i tried to commit a file, I did not have a
> default editor set up.

Clearly, the default editor you had was vim.
However, you didn't have a personal EDITOR or CVSEDITOR

> so it opened a vim editor to log in my messages.
> Since I am not familiar with vim, I killed th
> cvs commit job (using kill -9 pid). Then when I
> set the editor to be emacs it and tried to
> commit the same file I get the error message

> cvs commit: cvs commit: [11:28:28] waiting for melroy's lock
> [11:28:28]

> I looked at the past archives and cvs manual to
> look for this solution and it appears that this
> message occurs when two people simulatenously
> try to commit something. anyhow can someone
> suggest a simple solution?

You will need to go to the repository and remove
the cvs lock file for the directory. If you used
LockDir=<somepath> in the CVSROOT/config the lock
will be found under the <somepath> tree.
Otherwise, it will be in your
$CVSROOT/<path-to-module> directory.

> Is there alock file which I should look for and
> delete?

Yes. Read

it should help you identify what needs to be fixed.

        -- Mark

reply via email to

[Prev in Thread] Current Thread [Next in Thread]