[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Please help troubleshooting connection problem via SSH

From: Chris Weiss
Subject: Re: Please help troubleshooting connection problem via SSH
Date: Thu, 07 Oct 2004 13:58:15 -0700
User-agent: Mozilla Thunderbird 0.8 (Windows/20040913)

Chris Weiss wrote:

J. David Boyd wrote:

Chris Weiss <address@hidden> writes:

J. David Boyd wrote:

Chris Weiss <address@hidden> writes:

I've got one client who is having trouble connecting to our CVS
server. I'm trying to troubleshoot the problem, but am not having much

Our setup is CVS server 1.11.5, client, we're connecting via
SSH tunnel. We've got the keys syncronized, so the client doesn't need
to enter a password to connect.
I'm able to successfully connect using the client's account, but he is
not. We've been successfully using this system for a while with a
dozen users who are having no issues connecting.
He can SSH in, so we know it's not a blocked port issue.
The client's machine is WinXP (unknown if SP2 is installed)

Client-wise, we're using WinCVS and Turtle - I've tried CVS from the
command prompt as well with no success.

The symptoms are - if trying to do a Checkout or get a module list,
the client freezes with no output at all. We've left it for minutes at
a time with no response.
Here is the client's output for CVS Version:
Client: Concurrent Versions System (CVSNT)  (Build 57k)

Does anyone have any ideas what could be causing his issues or any
further steps to take to troubleshoot this? I'm new to the whole CVS
thing (my experience was all Perforce) and this is all a trial-by-fire
for me.

You say that you can use the client's account no problem, but you don't mean
his machine, just his login info,of course.  It sounds as if his
CVSROOT string is incorrect.  What did you all put into
the preferences section of WinCVS to connect him to your system?

That wouldn't stop him from manually SSHing into the system, but it would
certainly keep WinCVS from connecting.


I'm pretty sure it's not a CVSROOT issue unless there's something
machine specific in that variable. We'd set it multiple times over the
course of testing (it's not persistent in the shell) and several of
those times were copy/pastes from CVSROOT settings that worked
successfully on my machine (we've been debugging via IM).

I'm also guessing that if there was a bad CVSROOT, at least one of the
clients would have given a descriptive error and not just hung.

Thanks for the ideas though!

So you are saying that the client can connect to CVS through SSH on the
command line? Just not in WinCVS or Turtle? That definitely would not be a
CVSROOT problem then.

Sorry for being no help...

Sorry - that was my bad for being unclear. I meant that we're able to connect for an SSH shell session, so I know it's not an issue with SSH authentication or the port being blocked. We can't connected to the server regardless of the client being used.

I'll check out the -t argument.

FYI - the output of -t update is (the user/servernames have been changed to protect the innocent):

C:\>"c:\Program Files\gnu\WinCvs 1.3\cvs" -z9 -t  update
-> main loop with CVSROOT=<username>@cvs.<servername>.com:/usr/local/cvsroot

And that's it... it'll sit until we ctrl-C out of it...

This message has been scanned for viruses and
dangerous content, and is believed to be clean.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]