[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

CVS repository not found

From: Pavel Tsarenko
Subject: CVS repository not found
Date: 13 Nov 2004 23:33:57 -0800

Hi, all !

I am trying to checkout CVS in via
ssh protocol with TortoiseCVS 1.8.31. I generated key pair
by puttygen with SSH2 DSA. Then I have upload new public
key to sourceforge, and login from putty with new parameters
(ssh2 protocol) into sourceforge. Before login I run pageant
with private key and input my passphrase. The login is succesfull.
After then I have tried to perform checkout. Password isn't
asked from me, but the following messages is appeared:

<Begin message>

There is no CVS repository in this folder

/cvsroot/xharbour on

if this is the wrong folder, correct it and try again. If you want
to initialise a new repository with "cvs init" then check the box
and TortoiseCVS will try again

Initialise a new repository here (makes a CVSROOT folder)

In C:\Projects: "C:\Program Files\TortoiseCVS\cvs95.exe" "-q" "-z6"
"checkout" "-P" "xharbour"

Cannot access /cvsroot/xharbour/CVSROOT
No such file or directory

Error, CVS operation failed

Tortoise Tip:  Sometimes you get this error if you have the repository
folder wrong in the Checkout dialog.  Make sure you have a slash at
start of the folder name, and that the case and path are correct.
Watch out for spurious trailing characters.

Examples are:  "/cvsroot", "/usr/local/cvs-repository",

<end message>

The CVS repository exist and I can checkout it with anonymous access.
The CVSROOT string is the SAME as with anonymous
access except protocol parameter:


instead of


but CVS repository is not found via SSH. I don't understand the
reason of this.

Can anybody help to me ?


Best regards, Pavel Tsarenko

reply via email to

[Prev in Thread] Current Thread [Next in Thread]