[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: CVS repository not found

From: Arthur Barrett
Subject: Re: CVS repository not found
Date: Sun, 14 Nov 2004 22:04:38 GMT


If you are using TortoiseCVS then you are using the CVSNT client (it comes
bundled with Tortoise and does all the communications).  The correct place
to ask this question is the CVSNT newsgroup:



Arthur Barrett

"Pavel Tsarenko" <address@hidden> wrote in message
> Hi, all !
> I am trying to checkout CVS in via
> ssh protocol with TortoiseCVS 1.8.31. I generated key pair
> by puttygen with SSH2 DSA. Then I have upload new public
> key to sourceforge, and login from putty with new parameters
> (ssh2 protocol) into sourceforge. Before login I run pageant
> with private key and input my passphrase. The login is succesfull.
> After then I have tried to perform checkout. Password isn't
> asked from me, but the following messages is appeared:
> <Begin message>
> There is no CVS repository in this folder
> /cvsroot/xharbour on
> if this is the wrong folder, correct it and try again. If you want
> to initialise a new repository with "cvs init" then check the box
> below
> and TortoiseCVS will try again
> Initialise a new repository here (makes a CVSROOT folder)
> In C:\Projects: "C:\Program Files\TortoiseCVS\cvs95.exe" "-q" "-z6"
> "checkout" "-P" "xharbour"
> CVSROOT=:ext:address@hidden:/cvsroot/xharbour
> Cannot access /cvsroot/xharbour/CVSROOT
> No such file or directory
> Error, CVS operation failed
> Tortoise Tip:  Sometimes you get this error if you have the repository
> folder wrong in the Checkout dialog.  Make sure you have a slash at
> the
> start of the folder name, and that the case and path are correct.
> Watch out for spurious trailing characters.
> Examples are:  "/cvsroot", "/usr/local/cvs-repository",
> "/cvsroot/cvsgui"
> <end message>
> The CVS repository exist and I can checkout it with anonymous access.
> The CVSROOT string is the SAME as with anonymous
> access except protocol parameter:
> CVSROOT=:ext:address@hidden:/cvsroot/xharbour
> instead of
> CVSROOT=:pserver:address@hidden:/cvsroot/xharbour
> but CVS repository is not found via SSH. I don't understand the
> reason of this.
> Can anybody help to me ?
> Thanks
> Best regards, Pavel Tsarenko

reply via email to

[Prev in Thread] Current Thread [Next in Thread]