[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Re: not all files get imported

From: manisha r sankpal
Subject: Re: Re: not all files get imported
Date: 1 Dec 2004 06:32:58 -0000

hi all,
I have first tried to import all files using - I ! option but there was error like this
cvs: import.c:566: process_import_file: Assertion `entdata->options[0] == '-' &&
entdata->options [1] == 'k'' failed.
i have searched on net and found that the problem lies in importing directory that contains CVS subdirectories, but you told CVS to forget the default ignore list (-I!), so it tried to import the CVS subdirectories and got terminally confused.

So i have added  a -ICVS option and everything works fine.


On Wed, 01 Dec 2004 Pierre Asselin wrote :
>Spiro Trikaliotis <address@hidden> wrote:
> > * On Tue, Nov 30, 2004 at 06:56:04AM -0000 manisha r sankpal wrote:
> > > address@hidden test_prj >> import -m "log msg" test_prj username start
> > > but this command fails to check in one directory into the cvs. this
> > > dir contains only one *.o  file.
> > [ ... ]
> > If you want to circumvent this, use -I ! on your "cvs import".
>Spiro is correct.  To this I add:  if you want to repair your
>import just *repeat* it, this time with the -I! option.  Be sure
>and use the same release tag as in the initial, partial, import.
>Oh, and this assumes that you do want the .o file in your repository.
>If you just want the directory but not the file, that can't be done.
>CVS won't import empty directories.  Workarounds would be
>    1)  modify your build system to create the directory
>      after checkout, if it is missing;
>    2)  add an empty .dummy file before the import, so the
>      directory is no longer empty.
>pa at panix dot com
>Info-cvs mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]