[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Utter confusion

From: ai26
Subject: Re: Utter confusion
Date: Thu, 09 Dec 2004 00:04:38 +0100

In a message of Wed, 08 Dec 2004 14:42:58 -0800
Received on Wed, 08 Dec 2004 23:43:31 +0100

Mark D. Baushke <address@hidden> wrote
to: Michael Lemke <address@hidden>

>Hash: SHA1
>> >>
>> >> You could reverse the arguments of the merge operation as an
>> >> alternative...
>> >
>> >Well, that's an idea, why didn't I think of it...  But still no
>> >luck:
>> >
>> >$ cvs up -j DEVP_4 -j QP_LAST_WORKING_VERSION PATCH002.htm
>> >R PATCH002.htm
>> >cvs update: file PATCH002.htm exists, but has been added in revision
>> >
>> >and it's still not there.
>> >
>> What does it mean?
>Merges happen in a checked out tree using a three-way merge. If your
>tree is 'missing' the baseline version from your tree, 

Hm, this gets interesting.  I got similar messages when I did the
initial merge.  So the `missing baseline version' is the one in the
sandbox, right?  And `missing' means locally removed?

>then cvs assumes
>this was your intent and supresses doing the inverse of the merge. 

Does this only affect the inverse?  I'd guess not but I better ask.

>in this case, you will need to 'cvs add' the files back into your
>sandbox before you can completely restore things to the way they were
>before you did the botched merge operation.

Ok, I'll try this tomorrow.

Thanks again,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]