[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Arggg, I thought I had cvs worked out but I didn't

From: twoeyedhuman1111
Subject: Arggg, I thought I had cvs worked out but I didn't
Date: 29 Apr 2005 12:12:41 -0700
User-agent: G2/0.2

Okay, I used the advice to not install cvs as root, although for
permission reasons i did do some cvs commands as root.  I don't know
why but I still can't commit files, even if i'm not root.  This is what
I did:

1)  Unpacked/installed cvs as root
2)  modified the /etc/bashrc to include the lines:
      export CVSROOT

Around here is where I might have gone wrong:

3)  did "cvs init" as root (worked)
4)  did "cvs checkout CVSROOT" as root (worked)
5)  remembered the thing I was supposed to do as normal user and did
"cvs checkout CVSROOT" as normal user sean.  This did not work, it said
that I
can't checkout into the CVSROOT directory.
6)  did cvs "cvs edit config" as sean (worked)
7)  did cvs "cvs commit config" as sean.  this did not work as it said
the file config didn't exist

Does anyone know how I should change my steps to get cvs commit to work?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]