[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Arggg, I thought I had cvs worked out but I didn't

From: Mark D. Baushke
Subject: Re: Arggg, I thought I had cvs worked out but I didn't
Date: Sat, 30 Apr 2005 21:17:37 -0700

Hash: SHA1

twoeyedhuman1111 <address@hidden> writes:

> Okay, I used the advice to not install cvs as root, although for
> permission reasons i did do some cvs commands as root.  I don't know
> why but I still can't commit files, even if i'm not root.  This is what
> I did:
> 1)  Unpacked/installed cvs as root


> 2)  modified the /etc/bashrc to include the lines:
>       CVSROOT="/cvs"
>       export CVSROOT

This is probably not really necessary as any user could specify
the CVSROOT in their own environment or on the command line.

> Around here is where I might have gone wrong:
> 3)  did "cvs init" as root (worked)

And now all of the files and directories under /cvs are owned by root
and whatever account root was using at the time. This is not a good
thing. You probably need to do at least this (as yourself)

       % id 
       ...gid=nn0(name0) groups=nn1(name1),nn2(name2),nn3(name3)...

choose one of the groups of which you (and your other users) are a part
as the group for your /cvs repository.

       % chgrp -R nameN /cvs
       % find /cvs -type d -print |xargs chmod g+rwxs

now all of the directories should have write permissions for groupN users.

> 4)  did "cvs checkout CVSROOT" as root (worked)


> 5) remembered the thing I was supposed to do as normal user and did
> "cvs checkout CVSROOT" as normal user sean. This did not work, it said
> that I can't checkout into the CVSROOT directory.

You need to be able to create lock directories in the /cvs repository
and if it is owned by root and you are not a member of the group for the
directory, this will be a problem.

> 6)  did cvs "cvs edit config" as sean (worked)

Hmmm... I would have expected an error message if 'sean' is a normal user.

> 7)  did cvs "cvs commit config" as sean.  this did not work as it said
> the file config didn't exist

Summarizing the responses is not useful. Provide literal output from the
cvs commands you are giving.

> Does anyone know how I should change my steps to get cvs commit to work?

Have you considered reading the fine manual or any of the numerous books
on the subject?

        -- Mark
Version: GnuPG v1.2.3 (FreeBSD)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]