[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

error: /bin/sh : cvs: commanf not found

From: Nigel Leung
Subject: error: /bin/sh : cvs: commanf not found
Date: Sun, 8 May 2005 16:38:01 +0800

Hi everyone,


I am a newbie to cvs. Just recently managed to install cvs on my westhost vps (it wasn’t great at all, no root permission, no xinetd.conf access). I planned to tunnel cvs connection thru SSH connection because there is no xinetd config file available on my vps. Anyway, I seem to have successfully installed cvs-1.11.5 on that vps by attaching prefix during configure so that it installs at other location (/usr/local/libcvs/)

Everything looks good. CVSROOT has been setup correctly in .bashrc (CVSROOT=/usr/home/cvsroot; export CVSROOT). Path to cvs bin has also been included (export PATH="$PATH:/usr/local/libcvs/bin"). Did a cvs init, CVSROOT repository created successfully. Tried importing test projects, check in check out, all works.


However now I am stucked here. Those were performed during SSH session. i would like to use cvsgui (eg. tortoisecvs) to access my server. So I configure toirtoisecvs to connect to my server over SSH.


Below is the CVSROOT I put in tortoisecvs:


CVSROOT: ssh:address@hidden:22:/usr/home/cvsroot

And also this

CVSROOT:ext:address@hidden:/usr/home/cvsroot CVS_RSH=ssh1

I did even try this

CVSROOT:ext:address@hidden:/usr/home/cvsroot CVS_SERVER=/usr/local/libcvs/bin  CVS_RSH=ssh


All the above setting allows me to login. It did prompt me for password. However during the checkout it gave me this error: “ /bin/sh: cvs: command not found ”

I have tried various combination of CVSROOT however all of them returned me the same error, command not found. I re-checked back to server, login thru SSH (I use SSH Secure Client), did a cvs import, checkout, etc, they all works flawlessly.


I did try other gui (wincvs) and it gave me the same error as well.


I would be pleased and greatly appreciate if anyone can advise me accordingly.


Thank you very much.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]