[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Can't checkout to my C: root directly *PANIC* Admin Files Missing

From: Arno Schuring
Subject: RE: Can't checkout to my C: root directly *PANIC* Admin Files Missing
Date: Tue, 10 May 2005 21:28:11 +0000

I'm not sure, but I might have (at least) a clue for you...


I've tried 4 or 5 different Windows command-line versions of cvs.exe from (1.10.5 to 1.11.20). Created a folder called cvs directly under C:\, pointed the path stmt to it. Created Home=C: and CVSROO envrionment variables, etc and successfully logged in to our linux repository where CVS is kept.

Note that you say "created a folder called cvs directly under C:\"...

If I check out any of our CVS modules or projects from the main respository to any subfolder of my drive C: everything goes smoothly. However none of the versions of CVS I tried allow me to directly check out a project to the root. So when at the dos prompt and I type

C:\>cvs co -P newproj

I get these bizzare errors:

cvs checkout: in directory .:
cvs [checkout aborted]: *PANIC* administration files missing

I think cvs treats the 'cvs' dir found as its own administrative dir. It then fails because it expects CVS/Repository and CVS/Root to exist, which obviously don't. Remember that windows' filesystem is case insensitive...

I'm not exactly sure of this, though: I fail to reproduce this on my machine (though it is linux, not windows):

address@hidden:~/work> mkdir CVS
address@hidden:~/work> cvs up
cvs update: in directory `.':
cvs update: CVS directory found without administrative files.
cvs update: Use CVS to create the CVS directory, or rename the
cvs update: directory if it is intended to store something
cvs update: besides CVS administrative files.
cvs [update aborted]: *PANIC* administration files missing!
address@hidden:~/work> cvs --version

Concurrent Versions System (CVS) 1.12.11 (client/server)

but checkouts do succeed:
address@hidden:~/work> cvs co -P in4073
cvs checkout: Updating in4073

P.s. I meant to say WinXP desktop and Win2003 netwrk servers and repositories being on Linux servers. Thanks again


Hope this helps,


Information without knowledge is noise
knowledge without wisdom is dangerous stupidity

Play online games with your friends with MSN Messenger

reply via email to

[Prev in Thread] Current Thread [Next in Thread]