[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Can't checkout to my C: root directly *PANIC* Admin Files Missing

From: Mark D. Baushke
Subject: Re: Can't checkout to my C: root directly *PANIC* Admin Files Missing
Date: Tue, 10 May 2005 15:03:47 -0700

Hash: SHA1

Arno Schuring <address@hidden> writes:

> I'm not sure, but I might have (at least) a clue for you...
> >Hi
> >
> >I've tried 4 or 5 different Windows command-line versions of cvs.exe from 
> >(1.10.5 to 1.11.20). Created a folder called cvs directly under C:\, 
> >pointed the path stmt to it. Created Home=C: and CVSROO envrionment 
> >variables, etc and successfully logged in to our linux repository where CVS 
> >is kept.
> Note that you say "created a folder called cvs directly under C:\"...
> >
> >If I check out any of our CVS modules or projects from the main respository 
> >to any subfolder of my drive C: everything goes smoothly.  However none of 
> >the versions of CVS I tried allow me to directly check out a project to the 
> >root.  So when at the dos prompt and I type
> >
> >C:\>cvs co -P newproj
> >
> >I get these bizzare errors:
> >
> >cvs checkout: in directory .:
> >cvs [checkout aborted]: *PANIC* administration files missing
> I think cvs treats the 'cvs' dir found as its own administrative dir. It 
> then fails because it expects CVS/Repository and CVS/Root to exist, which 
> obviously don't. Remember that windows' filesystem is case insensitive...
> I'm not exactly sure of this, though: I fail to reproduce this on my machine 
> (though it is linux, not windows):

Note: the 'TopLevelAdmin=yes' item in CVSROOT/config controls if a
top-level 'CVS' administrative directory should be used. If your
repository does not specify that option, then you won't care if there is
a 'CVS' directory in your root or not.

        -- Mark
Version: GnuPG v1.2.3 (FreeBSD)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]