[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Can't checkout to my C: root directly *PANIC* Admin Files Missing

From: S I
Subject: Re: Can't checkout to my C: root directly *PANIC* Admin Files Missing
Date: Tue, 10 May 2005 19:31:42 -0700

Do I set this value on the server side?  I'll look at it. Thanks


----Original Message Follows----
From: "Mark D. Baushke" <address@hidden>
To: "Arno Schuring" <address@hidden>
CC: address@hidden, address@hidden
Subject: Re: Can't checkout to my C: root directly *PANIC* Admin Files Missing
Date: Tue, 10 May 2005 15:03:47 -0700
MIME-Version: 1.0
Received: from ([]) by with Microsoft SMTPSVC(6.0.3790.211); Tue, 10 May 2005 15:04:04 -0700 Received: from ( [])by (8.12.3/8.12.3) with ESMTP id j4AM42Bm006984;Tue, 10 May 2005 15:04:02 -0700 (PDT)(envelope-from address@hidden) Received: from ( [])by (8.11.3/8.11.3) with ESMTP id j4AM3me54571;Tue, 10 May 2005 15:03:48 -0700 (PDT)(envelope-from address@hidden)
X-Message-Info: yilqo4+6kc4BVcOy2h5wQXRXGeD9+5YH1EL7Z4lDxHk=
References: <address@hidden>
X-Mailer: MH-E 7.83+cvs; nmh 1.0.4; GNU Emacs 21.3.1
X-Face: #8D_6URD2G%vC.hzU<dI&#Y9szHj$'mGtUq&d=rXy^L$-=G_-LmZ^5!Fszk:yXZp$k\nTF? 8Up0!v/%1Q[(d?ES0mQW8dRCXi18gK)luJu)loHk,}4{Vi`yX?p?crF5o:LL{6#eiO:(E:YMxLXULB k|'a*EjN.B&L+[J!PhJ*aX0n:5/
Mail-Followup-To: info-cvs <address@hidden>
Return-Path: address@hidden
X-OriginalArrivalTime: 10 May 2005 22:04:05.0334 (UTC) FILETIME=[2E882F60:01C555AC]

Hash: SHA1

Arno Schuring <address@hidden> writes:

> I'm not sure, but I might have (at least) a clue for you...
> >Hi
> >
> >I've tried 4 or 5 different Windows command-line versions of cvs.exe from
> >(1.10.5 to 1.11.20). Created a folder called cvs directly under C:\,
> >pointed the path stmt to it. Created Home=C: and CVSROO envrionment
> >variables, etc and successfully logged in to our linux repository where CVS
> >is kept.
> Note that you say "created a folder called cvs directly under C:\"...
> >
> >If I check out any of our CVS modules or projects from the main respository > >to any subfolder of my drive C: everything goes smoothly. However none of > >the versions of CVS I tried allow me to directly check out a project to the
> >root.  So when at the dos prompt and I type
> >
> >C:\>cvs co -P newproj
> >
> >I get these bizzare errors:
> >
> >cvs checkout: in directory .:
> >cvs [checkout aborted]: *PANIC* administration files missing
> I think cvs treats the 'cvs' dir found as its own administrative dir. It
> then fails because it expects CVS/Repository and CVS/Root to exist, which
> obviously don't. Remember that windows' filesystem is case insensitive...
> I'm not exactly sure of this, though: I fail to reproduce this on my machine
> (though it is linux, not windows):

Note: the 'TopLevelAdmin=yes' item in CVSROOT/config controls if a
top-level 'CVS' administrative directory should be used. If your
repository does not specify that option, then you won't care if there is
a 'CVS' directory in your root or not.

        -- Mark
Version: GnuPG v1.2.3 (FreeBSD)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]