[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Cannot remove directories from the CVS repository

From: Peter Desjardins
Subject: Cannot remove directories from the CVS repository
Date: Wed, 6 Jul 2005 10:08:22 -0400

There is a directory with a few empty subdirectories stuck in my CVS
repository.  I've worked with my local IT expert and checked through
several CVS mailing list archives.

A few weeks ago I renamed a directory in my CVS module.  I did this by
making a copy of the directory, using the "release" command for the
copy, renaming the copy, using "cvs add" for the new name directory, and
using "cvs remove" for the old name directory.  It seems that the old
name directory was not removed correctly.  Now when I checkout the
module, the old name directory appears in my working directory with a
small number of its subdirectories and CVS control files.  However, it
does not contain any of the content files.  The new named directory has
been working perfectly.

At the time I tried this renaming, I was using Windows XP and
TortoiseCVS to manage my module.  Since then I have switched to Windows
XP and the Cygwin command line.

Right now, if I checkout the module, CVS will create the old name
directory and some of its subdirectories in my working directory.  Then
if I use "cvs update -P" immediately after the checkout, CVS will
include the following message for the old name directory and each of
those subdirectories:

cvs update: cannot remove directoryX/subdirectoryY: Directory not empty 

The directories are empty in my working directory; I checked with "ls
-a".  How can I get the old name directory out of the repository?  Has
anyone else seen a message like this?

Thanks for your help.

Peter Desjardins
SupplyScape Corporation

reply via email to

[Prev in Thread] Current Thread [Next in Thread]