[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Setting up first repository [Solved]

From: Roddie
Subject: Re: Setting up first repository [Solved]
Date: Mon, 18 Jul 2005 12:37:03 +0100
User-agent: Microsoft-Entourage/

on 18/7/05 10:49, Roddie at address@hidden wrote:

> on 10/3/05 2:48, Pierre Asselin at address@hidden wrote:
>> Roddie <address@hidden> wrote:
>>> [a test repository] is a good idea and I've been trying it.
>>> I can log in OK, but when I try
>>> to import a trial project using "cvs -d
>>> :pserver:address@hidden:/usr/local/CVS import myProj no-vendor release-0"
>>> I get "cvs [import aborted]: reading CVS/Tag: Not a directory".
>> pserver ?  Why not just :local:/usr/local/CVS ?  No xinetd, no login,
>> no passwords to set up...
>> When you put a cvs server on your colocation box I recommend :ext:
>> with CVS_RSH=ssh and public key authentication.  I assume
>> you already have the ssh part set up ?  Othwerwise how do you
>> reach your colocated machine ?
> I'm now trying to get the repository on the co-lo working, but I'm confused.
> ssh works fine and I have "CVS_RSH ssh" in my .tcshrc. When I connect to the
> server with ssh it asks for a password, but :ext: seems to not use
> passwords. How is this secure? But I can't connect anyway:
> "cvs -d :ext:address@hidden:/var/lib/cvsroot import cvstest
> cvstest_project ver_0-1"
> returns (after a pause of several seconds)
> " Connection refused"
> A separate question, I think... Creating a repository seemed to work (I'm
> following Jennifer Vesperman's book). How can I check that a repository
> exists?

I've been able to connect. It was a matter of tweaking ssh settings. And it
asks for a password.


Roddie Grant

reply via email to

[Prev in Thread] Current Thread [Next in Thread]