[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cvs rtag -a

From: Ana Oleski
Subject: Re: cvs rtag -a
Date: Wed, 20 Jul 2005 07:53:04 -0800


but it's not a branch I'm moving, it's a normal tag. 

I tried it anyway
  cvs rtag -a -F -B -r rel_5_1 latest_stable module_name

with the result that cvs refused to move anything:

cvs rtag: module_name/SomeFile: Not moving non-branch tag `latest_stable' from 
1.1 to
1.2 due to `-B' option.

Which does make sense. 

What we do now is delete and add
  cvs rtag -d latest_stable module_name
  cvs rtag -r rel_5_1 latest_stable module_name

It does what we want, it just takes looooonger :-)

Quoting "Mark E. Hamilton" <address@hidden>:

> Ana,
> You might try using the '-B' option to rtag. This was added in 1.11.2 
> and affects to the '-F' option; it may affect the '-a' as well (I've not 
> tried it.)
>  From NEWS, it seems logical that it would apply to '-a':
> * The "tag" and "rtag" commands will no longer move or delete branch
> tags unless you use the new -B option.  (This prevents accidental
> changes to branch tags that are hard to undo.)
> Ana Oleski wrote:
> > Hi,
> > 
> > we've upgraded from cvs 1.11 to cvs 1.11.18 some time ago and it seems
> the -a flag in
> > cvs rtag stopped working.
> > 
> > We have a floating tag that we move periodically to the latest stable
> version,
> > for example:
> > 
> >     cvs rtag -a -F -r rel_5_1 latest_stable module_name
> > 
> > The problem is that files that have been removed and are no longer in
> rel_5_1 still
> > keep their "latest_stable" tag, although -a should clear the tag from
> attic files. Or
> > at least it used to in 1.11
> > 
> > Is it a bug? Or is this feature no longer supported?  
> > 
> > Ana
> -- 
> ----------------
> Mark E. Hamilton
> Orion International Technologies, Inc.
> Sandia National Laboratory, NM.
> 505-844-7666

Voice Messages, Voice Calls (VoIP), Video Conferencing,
Anonymous SSL Web Surfing,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]