[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Unable to release - why? - SOLVED

From: Doug Lee
Subject: Re: Unable to release - why? - SOLVED
Date: Fri, 26 Aug 2005 10:42:15 -0400
User-agent: Mutt/1.5.9i

Cygwin (full install) did NOT create an sh executable or link, though
I got at least bash and tcsh.  The following Cygwin command fixed the
`cvs release' problem:

ln -s /bin/bash /bin/sh

Remaining question:  Should this have been necessary??

On Fri, Aug 26, 2005 at 10:31:31AM -0400, Doug Lee wrote:
On Thu, Aug 25, 2005 at 12:27:11PM -0400, Doug Lee wrote:
>On Thu, Aug 25, 2005 at 11:59:14AM -0400, Larry Jones wrote:
>> Doug Lee writes:
>> > 
>> > I tried with and without the second -d, but the result was always the
>> > same:  "cvs release: unable to release `proj'."
>> Were there any other messages?  The first thing release does is to run
>> update to find out if there are any modified files in the directory. 
>> That message indicates that the update exited with a failure status
>> (which shouldn't happen).
>No other messages, and cvs update works, even when I do it from the
>directory above the top level (as with release):
>cvs -d /cygdrive/f/cvsr update proj
>I even tried releasing a specific directory in the checkout:
>cd proj
>cvs release [-d] dir1
>but I got the same message.  I also tried setting the CVSROOT
>environment variable (it's usually not set) to make sure I didn't typo
>something.  No problem there either.

More news:  I finally thought to run `cvs -t release proj' with the
following results:

 -> main loop with CVSROOT=/cygdrive/f/cvsr
 -> run_popen(cvs -n -q -d /cygdrive/f/cvsr update,r)
cvs release: unable to release `proj'
 -> Lock_Cleanup()

 So now I suspect popen problems, problems popping a shell, etc.
 Other cvs commands work fine.  I can run shells and subcommands from
 within vim though.  I've now tried `cvs release' commands from both
 tcsh and bash; no luck.

 Requoting my (corrected) initial description below in case it elps.

>I just checked out a large collection of files with a command like
>cvs -d /cygdrive/f/cvsr proj
>then tagged the whole thing (and figured out I didn't need to check it
>out in the first place) like this
>cvs -d /cygdrive/f/cvsr rtag tag1 proj
>then moved one tag manually
>cd proj/dir1
>cvs tag -F tag1 file1.txt
>All this worked.  Then I tried to release the checkout:
>cd ../..
>cvs -d /cygdrive/f/cvsr release -d proj
>I tried with and without the second -d, but the result was always the
>same:  "cvs release: unable to release `proj'."
>This is CVS 1.11.17 (client-server) as came with a very recent full
>installation of Cygwin.  I run it under Cygwin (tcsh) on Windows XP
>Pro with the latest service packs and critical updates.  Drive F is a
>thumb drive.  The CVSROOT/history file does show an O record for my
>checkout, and it has 644 perms and is owned by me.
>Anyone know why I can't release?
>Thanks much.

Doug Lee           address@hidden
BART Group         address@hidden
"A mailing list is a crude but effective cross between a
chain letter and a shouting match."  -Andrew Kantor

Doug Lee           address@hidden
BART Group         address@hidden
"Believe, when you are most unhappy, that there is something for you
to do in the world. So long as you can sweeten another's pain, life is
not in vain." --Helen Keller

reply via email to

[Prev in Thread] Current Thread [Next in Thread]