[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Unable to release - why? - SOLVED

From: Doug Lee
Subject: Re: Unable to release - why? - SOLVED
Date: Fri, 26 Aug 2005 11:13:03 -0400
User-agent: Mutt/1.5.9i

On Fri, Aug 26, 2005 at 10:56:52AM -0400, Larry Jones wrote:
> Doug Lee writes:
> > 
> > Cygwin (full install) did NOT create an sh executable or link, though
> > I got at least bash and tcsh.  The following Cygwin command fixed the
> > `cvs release' problem:
> > 
> > ln -s /bin/bash /bin/sh
> > 
> > Remaining question:  Should this have been necessary??
> That depends on your perspective.  :-)
> popen is specifically defined as running sh, so you need *some* /bin/sh.
> The cygwin version seems to be ash, but bash should be acceptable.  I
> would have thought that a full install should have included ash.

It does, but not a link to it named /bin/sh, so popen didn't find it.
I relinked /bin/sh to /bin/ash as a result of your message; I'd never
noticed ash before.

Doug Lee           address@hidden
BART Group         address@hidden
"Never does the human soul appear so strong as when it foregoes
revenge, and dares forgive an injury." --E. H. Chapin

reply via email to

[Prev in Thread] Current Thread [Next in Thread]