[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Unable to release - why? - SOLVED

From: Dave Korn
Subject: RE: Unable to release - why? - SOLVED
Date: Fri, 26 Aug 2005 17:30:22 +0100

----Original Message----
>From: Doug Lee
>Sent: 26 August 2005 15:42

> Cygwin (full install) did NOT create an sh executable or link, though
> I got at least bash and tcsh.  The following Cygwin command fixed the
> `cvs release' problem:
> ln -s /bin/bash /bin/sh

  That was a bug in the cygwin bash package.  It only existed for a couple
of days late last month (or was it early this month?); you must have been
unlucky and installed cygwin at just that time.  The problem was related to
a decision to switch over cygwin's default /bin/sh from being ash to being
bash; it was meant to delete the old /bin/sh and create the symlink that you
did manually, but owing to a bug it only deleted the old /bin/sh and didn't
correctly make the symlink.

> Remaining question:  Should this have been necessary??

  You could have solved this by re-running cygwin setup and reinstalling the
bash package, or by manually re-running the postinstall script, or (as you
in fact did) manually creating the symlink; your fix is correct, and you
should have no further problems.

Can't think of a witty .sigline today....

reply via email to

[Prev in Thread] Current Thread [Next in Thread]