[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Unable to increment revision number

From: Jim Hyslop
Subject: Re: Unable to increment revision number
Date: Tue, 13 Sep 2005 14:47:28 -0400
User-agent: Mozilla Thunderbird 1.0.6 (Windows/20050716)

Christopher Cheng wrote:
Thanks for the guide, I will definitely try that. By the way, I tried to
edit the file myself. I am able to run 'cvs log -h'

RCS file: /cvsroot/espresso/web/WEB-INF/conf/struts-references.xml,v
Working file: struts-references.xml
head: 1.23
locks: strict
access list:
symbolic names:
keyword substitution: kv
total revisions: 24

However, 'cvs update -A' still doesn't get me 1.23. That's very strange. Any

There may be more corruption remaining in the file - hopefully you have not introduced any further problems. I hope you backed up the file before changing it.

Stop what you are doing now, download the validate_repo script and run it. Since you're running CVSNT, I'm guessing you're using Windows, in which case you will also have to download and install Cygwin, or some other UNIX-like shell, to run the script.

*Please* take the time to do this now, before your repository becomes more corrupted.

Earlier, Larry mentioned:
If you have a recent backup that isn't also
corrupted, you should probably restore it.

Do you have recent backup of the repository? If so, you will likely be further ahead to restore the corrupt file(s) from your backup, rather than trying to muddle your way through the RCS file, which risks further corruption.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]