[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Unable to increment revision number

From: Christopher Cheng
Subject: RE: Unable to increment revision number
Date: Wed, 14 Sep 2005 11:20:08 +0800

Let's say I know the RCS file is completely corrupted and I want it to
eradicate the file permanently. That means I want the file back to 1.1, how
could I do that?

-----Original Message-----
From: Christopher Cheng [mailto:address@hidden 
Sent: Wednesday, September 14, 2005 10:56 AM
To: 'Jim Hyslop'
Cc: 'Larry Jones'; 'Dave Korn'; 'address@hidden'
Subject: RE: Unable to increment revision number

I was trying to run the script with perl on windows. It says "can't

C:\Java\espresso>perl -v
Verbose Mode Turned On
Can't stat
0.200:\cvsroot\espresso: No such file or directory
 at line 273
Total Files: 0  Corrupted files: 0  Invalid revs: 0  Extra files: 0  Ignored
Files: 0 Total Revisions: 0  Interesting Revisions: 0

I also tried to run with 

Still no luck...

-----Original Message-----
From: Jim Hyslop [mailto:address@hidden 
Sent: Wednesday, September 14, 2005 2:47 AM
To: Christopher Cheng
Cc: 'Larry Jones'; 'Dave Korn'; address@hidden
Subject: Re: Unable to increment revision number

Christopher Cheng wrote:
> Thanks for the guide, I will definitely try that. By the way, I tried to
> edit the file myself. I am able to run 'cvs log -h'
> RCS file: /cvsroot/espresso/web/WEB-INF/conf/struts-references.xml,v
> Working file: struts-references.xml
> head: 1.23
> branch:
> locks: strict
> access list:
> symbolic names:
>       r1-1-1:
>       r1-1:
> keyword substitution: kv
> total revisions: 24
> However, 'cvs update -A' still doesn't get me 1.23. That's very strange.
> idea?

There may be more corruption remaining in the file - hopefully you have 
not introduced any further problems. I hope you backed up the file 
before changing it.

Stop what you are doing now, download the validate_repo script and run 
it. Since you're running CVSNT, I'm guessing you're using Windows, in 
which case you will also have to download and install Cygwin, or some 
other UNIX-like shell, to run the script.

*Please* take the time to do this now, before your repository becomes 
more corrupted.

Earlier, Larry mentioned:
> If you have a recent backup that isn't also
> corrupted, you should probably restore it.

Do you have recent backup of the repository? If so, you will likely be 
further ahead to restore the corrupt file(s) from your backup, rather 
than trying to muddle your way through the RCS file, which risks further 


reply via email to

[Prev in Thread] Current Thread [Next in Thread]